40 lines
763 B
Nix
40 lines
763 B
Nix
{
|
|
fetchFromGitHub ,
|
|
pkgs ,
|
|
stdenv ,
|
|
} :
|
|
|
|
with pkgs . python311Packages ;
|
|
with stdenv ;
|
|
|
|
mkDerivation {
|
|
pname = "python-bw-file-resubmit" ;
|
|
version = "2023-11-08-0655eb2" ;
|
|
|
|
src = fetchFromGitHub {
|
|
owner = "bookwyrm-social" ;
|
|
repo = "bw-file-resubmit" ;
|
|
rev = "0655eb24d77b5440f0221df99d87bbb1ea588181" ;
|
|
hash = "sha256-RT3fF2oMsf0klUwMBJ02Dgdt2rsoB7A3SjiuyVuYU7A=" ;
|
|
} ;
|
|
|
|
dontPatch = true ;
|
|
dontConfigure = true ;
|
|
dontBuild = true ;
|
|
|
|
installPhase = ''
|
|
runHook preInstall
|
|
|
|
mkdir -p $out/lib/python3.11/site-packages
|
|
|
|
# Dependencies
|
|
|
|
ln -s ${django}/lib/python3.11/site-packages/* $out/lib/python3.11/site-packages/
|
|
|
|
# The package itself
|
|
|
|
cp -r $src/src/file_resubmit $out/lib/python3.11/site-packages/
|
|
|
|
runHook postInstall
|
|
'' ;
|
|
}
|